Tried to download carbon but failed

Posted in CategoryGeneral Discussion
  • Terry Ogbemudia 3 months ago
    No issues, just let me know if you face any other issue 
  • Shaun Collins 3 months ago
    That worked Terry, thank you so much mate, I was getting a bit dishearted!
  • Terry Ogbemudia 3 months ago

    Run $ composer clearcache


  • Shaun Collins 3 months ago
    Hi Terry, sorry to bug you but how do I clear the composer cache, is it the cache folder in the bootstrap directory?
  • Terry Ogbemudia 3 months ago

    Sorry I think it should be  netbot/carbon:1.26.3 maybe you also need to clear composer cache but it has Notting to do with php version. If this doesn’t solve the problem let me know I will connect and help fix

  • Shaun Collins 3 months ago
    Does not download Terry, I am using PHP 7, does that make a difference?
  • Terry Ogbemudia 3 months ago
    Ah okay, sorry for late response. Try installing a specific version composer install netbot/carbon:1.2.6
  • Shaun Collins 3 months ago

    Hi Terry,

    tried to download carbon but it failed, saying requirements could not be resolved to an installable set of packages. Is there another pakage I could install in its place? Maybe chronos!

    Using version ^2.10 for nesbot/carbon

    ./composer.json has been updated

    Loading composer repositories with package information

    Updating dependencies (including require-dev)

    Your requirements could not be resolved to an installable set of packages.


      Problem 1

        - illuminate/support 5.7.19 requires nesbot/carbon ^1.26.3 -> satisfiable by nesbot/carbon[1.26.3, 1.26.4, 1.27.0, 1.28.0, 1.29.0, 1.29.1, 1.29.2, 1.30.0, 1.31.0, 1.31.1, 1.32.0, 1.33.0, 1.34.0, 1.34.1, 1.34.2, 1.34.3, 1.34.4, 1.35.0, 1.35.1, 1.36.0, 1.36.1, 1.36.2] but these conflict with your requirements or minimum-stability.

        - illuminate/support 5.7.19 requires nesbot/carbon ^1.26.3 -> satisfiable by nesbot/carbon[1.26.3, 1.26.4, 1.27.0, 1.28.0, 1.29.0, 1.29.1, 1.29.2, 1.30.0, 1.31.0, 1.31.1, 1.32.0, 1.33.0, 1.34.0, 1.34.1, 1.34.2, 1.34.3, 1.34.4, 1.35.0, 1.35.1, 1.36.0, 1.36.1, 1.36.2] but these conflict with your requirements or minimum-stability.

        - illuminate/support 5.7.19 requires nesbot/carbon ^1.26.3 -> satisfiable by nesbot/carbon[1.26.3, 1.26.4, 1.27.0, 1.28.0, 1.29.0, 1.29.1, 1.29.2, 1.30.0, 1.31.0, 1.31.1, 1.32.0, 1.33.0, 1.34.0, 1.34.1, 1.34.2, 1.34.3, 1.34.4, 1.35.0, 1.35.1, 1.36.0, 1.36.1, 1.36.2] but these conflict with your requirements or minimum-stability.

        - Installation request for illuminate/support (locked at 5.7.19) -> satisfiable by illuminate/support[5.7.19].



    Installation failed, reverting ./composer.json to its original content.

    Tried to upload an image and screenshot link, but this form imput is playing up!

Please login or register to leave a response.